Author Topic: [Confirm V20]Enemy Running Animation Won't stop  (Read 4538 times)

Daithi

  • Global Moderator
  • Hero Member
  • *****
  • Posts: 1247
Re: [Fix Req]Enemy Running Animation Won't stop
« Reply #30 on: August 23, 2017, 06:44:33 PM »
In either Sam or Ray example, was it possible that second attack was AOO? If the enemy was killed before moved, it might not be clear. Equally possible there's another issue with OW issue. Yeah that would be good, maybe get some sort of idea what's happening...

Daithi

  • Global Moderator
  • Hero Member
  • *****
  • Posts: 1247
Re: [Fix Req]Enemy Running Animation Won't stop
« Reply #31 on: August 23, 2017, 06:58:21 PM »
Have fixed the issue with HTH OW attack on last tile, but don't have great confidence that this is the end of the issues. Going to test some variations on this.

ushas

  • Hero Member
  • *****
  • Posts: 661
Re: [Fix Req]Enemy Running Animation Won't stop
« Reply #32 on: August 23, 2017, 08:23:59 PM »
In either Sam or Ray example, was it possible that second attack was AOO? If the enemy was killed before moved, it might not be clear. Equally possible there's another issue with OW issue. Yeah that would be good, maybe get some sort of idea what's happening...
Attaching Ray's case - starts at the beginning of the movement order up to the end turn, at least I think so. Was also thinking about AOO, but according to the log seems there are two OW attacks. This looks very similar to the issue during v18. Another interesting thing is that the guy got into the error right after the second Ray's OW attack, before he himself attacked. On the screen I saw the looped animation later.

There is one more thing, I'm confused about: Can enemies decide to flee before their turn? I've seen Emilia shooting in overwatch a guy before it was his turn, and once the queue moved to him he starts to flee. I think it was the same guy as the one who got into looped running animation with Ray before.

Daithi

  • Global Moderator
  • Hero Member
  • *****
  • Posts: 1247
Re: [Fix Req]Enemy Running Animation Won't stop
« Reply #33 on: August 23, 2017, 08:47:33 PM »
Yeah, looks like it's 2x overwatch. It's a successful melee attack on 1st OW, will follow the code to see if there's a case in which overwatcher isn't removed, or wrong overwatcher is removed (was there anyone else overwatching at the same time?)

The decision to flee happens at beginning of turn, before search for orders. Shot shouldn't be fired until character reaches first tile. Could be another error.

ushas

  • Hero Member
  • *****
  • Posts: 661
Re: [Fix Req]Enemy Running Animation Won't stop
« Reply #34 on: August 23, 2017, 08:56:57 PM »
Yeah, I was trying to put on overwatch more party members. Not sure if on that specific turn. However, there wasn't any other ally nearby and Ray was the only guy who got the OW at this enemy, IIRC.

Ok. I will try to catch that preliminary OW without combination with running animation loop... Wish me luck:)

Daithi

  • Global Moderator
  • Hero Member
  • *****
  • Posts: 1247
Re: [Fix Req]Enemy Running Animation Won't stop
« Reply #35 on: August 23, 2017, 08:59:17 PM »
Good luck :) Have done a good bit of testing on OW, melee, single shot ranged, burst, attacking at start of path/end of path - nothing new yet.

Daithi

  • Global Moderator
  • Hero Member
  • *****
  • Posts: 1247
Re: [Fix Req]Enemy Running Animation Won't stop
« Reply #36 on: August 23, 2017, 09:04:41 PM »
Just got it to happen. I have a keycode to force enemies to flee (maybe should add that into build, but hidden to avoid accidental use). Sam went on melee overwatch. AOO triggered as enemy moved, then 2x OW on first tile moved to. There's an error thrown where the character is removed from OW list, so will have a look at that now.

Edit: Looks like a caused this with a debug statement. Maybe it's time to call it a day  :)
« Last Edit: August 23, 2017, 09:07:53 PM by Daithi »

ushas

  • Hero Member
  • *****
  • Posts: 661
Re: [Fix Req]Enemy Running Animation Won't stop
« Reply #37 on: August 24, 2017, 02:20:44 AM »
This was a double-edged luck, I tell you. Not sure I wanted to experience...

Moving dead bodies!
-- Having a good time with churchers.
-- Brother Karlsson got himself into running animation loop. As usual.
-- So we KO him, hoping that puts the loop to rest too... Except it doesn't.
-- Attached excerpt from the log starts at the last Karlsson's movement error. He is already KOed at the time.
-- Elena ends her turn with overwatch (Bellum). The next follows the turn of brother Iva.
-- It's fuzzy but I think Elena shot her overwatch attack before Iva moves.
-- Then I realized, Karlsson's body disappeared during the above OW action!
-- Found him under Ray's feet, see attached image how I think it moved (the arrow).
-- In the log Elena's attack was done at distance 1 and Ray's tile is indeed next to her.
-- I've marked which one is Iva - he is further away from her.
-- And indeed the log indicates the damage was done to Karlsson's body, if I read that well (it's mixed within Iva's turn)
-- Iva does his stuff and ends the turn.

I think (aka hope) this is is the pre-movement OW I was experiencing before, and thus it probably relates to the running animation loop issue. But who knows...

PS: Ups. It told me upload folder is full... But my files aren't big. So I went and removed some attachments from old resolved reports about map clippings. Seems helped for now... I hope you don't mind.  ;D

Daithi

  • Global Moderator
  • Hero Member
  • *****
  • Posts: 1247
Re: [Fix Req]Enemy Running Animation Won't stop
« Reply #38 on: August 24, 2017, 07:22:02 AM »
Was the running issue caused by a melee attack, possibly at the end of the movement? What's possibly happening with OW triggering before attack - if Karlsson is still considered to be moving this might be picked up by another overwatching character. Will try to tighten this up by making sure that character is no longer moving - though, if the root issue is the one I've fixed, this problem won't happen anymore.

Ha, thanks, you're also responsible for server maintenance now :) Will look at the hosting and clear out some threads/delete emails (incase the hosting space is shared)

Daithi

  • Global Moderator
  • Hero Member
  • *****
  • Posts: 1247
Re: [Fix Req]Enemy Running Animation Won't stop
« Reply #39 on: August 24, 2017, 12:28:05 PM »
Have done extensive testing on overwatch. That's not to say there won't be any issues in the future, but the feature should be much more stable in V20.

ushas

  • Hero Member
  • *****
  • Posts: 661
Re: [Fix Req]Enemy Running Animation Won't stop
« Reply #40 on: August 24, 2017, 01:04:14 PM »
Was the running issue caused by a melee attack, possibly at the end of the movement? What's possibly happening with OW triggering before attack - if Karlsson is still considered to be moving this might be picked up by another overwatching character. Will try to tighten this up by making sure that character is no longer moving - though, if the root issue is the one I've fixed, this problem won't happen anymore.
Yeah, I think it was something like that. But he was already down during this event. Think I backed up the whole log, if needed.

All I demonstrated with that feeble attempt at investigation is that there is suspicious correlation with running animation loop. And that's good, because it's possible you have it all fixed by now, judging from the posts.

Ha, thanks, you're also responsible for server maintenance now :) Will look at the hosting and clear out some threads/delete emails (incase the hosting space is shared)
Oh, well.  :-[
I decided to trim the images and upload it here instead of using public sharing services, also so you can easily delete stuff no longer valid yourself. Though, don't hesitate to give me different instructions if anything.