Author Topic: Mac version: Complications  (Read 1144 times)

Chabbrik

  • Newbie
  • *
  • Posts: 43
Mac version: Complications
« on: November 25, 2016, 08:28:06 AM »
Hello guys,

Last night I installed Mac Version of Vigilantes, to be able to test it on my Mac machine.
Once downloaded, I tried to run it, but it complained that software is coming from untrusted developer. So I had to go to system preferences to allow it to run.

After digging around how to solve this issue, it seems that it is necessary to sign up for Apple Developer programme and sign your package with your key. Perhaps it is an overkill to do in alpha. It will become a necessity once the release date draws nearer.

On the side but related note - it would be nice to have a DMG that cleanly installs the game in Applications. But it is a job that can be done in the future.

Daithi

  • Global Moderator
  • Hero Member
  • *****
  • Posts: 1231
Re: Mac version: Complications
« Reply #1 on: November 25, 2016, 03:32:08 PM »
I pretty much assumed the warning was a standard warning for Windows and Mac. Thanks for the pointer on how to solve. Probably won't do this right away, hopefully each version doesn't need to be approved, or it could end up as a moderate time overhead.

Chabbrik

  • Newbie
  • *
  • Posts: 43
Re: Mac version: Complications
« Reply #2 on: November 26, 2016, 08:58:37 AM »
I do not think it needs to be approved. Just signed with your developer key, when you are building your Mac project.

Daithi

  • Global Moderator
  • Hero Member
  • *****
  • Posts: 1231
Re: Mac version: Complications
« Reply #3 on: November 26, 2016, 01:23:14 PM »
Ah, great. That sounds worthwhile. Thanks!